第 37 章 系统需求

这部分描述了 Zend Framework 对系统的需求。

37.1. PHP 版本需求

Zend Framework 需要 PHP 5.1.4 或更高版本。例如 Countable 这样一些 SPL 接口在 PHP 之前的版本中没有被正式使用。

Zend Framework 提供了大量自动化测试,可以使用 PHPUnit 3.0 或更高版本运行。 这个版本的 PHPUnit 同样也需要 PHP 5.1.4 或更高版本。

虽然 Zend Framework 可以在上面提到的 PHP 版本下正确工作,但是强烈建议使用 PHP 5.2.2 或更高版本。 新版本的 PHP 有许多重要的安全更新和性能提升。